Executed commands:
  1. rm -f .revision.time
  2. make update-unicode -j6
  3. make update-download -j6
  4. make update-rubyspec -j6
  5. make update-src -j6
  6. make after-update -j6
  7. make miniruby -j6
  8. make ruby -j6
  9. make all -j6
  10. make install -j6
 
#<BuildRuby:0x000055b63fb8cf90 @REPOSITORY="https://github.com/ruby/ruby.git", @REPOSITORY_TYPE=:git, @git_branch=nil, @svn_revision=nil, @TARGET_NAME="trunk_gcc4", @SRC_DIR="/tmp/ruby/v3/src", @BUILD_DIR="/tmp/ruby/v3/build", @INSTALL_DIR="/tmp/ruby/v3/install", @TARGET_SRC_DIR="/tmp/ruby/v3/src/trunk_gcc4", @TARGET_BUILD_DIR="/tmp/ruby/v3/build/trunk_gcc4", @TARGET_INSTALL_DIR="/tmp/ruby/v3/install/trunk_gcc4", @configure_opts=["CC=gcc-4.8"], @build_opts="-j6", @test_opts="TESTS='-j6'", @incremental=true, @steps=["checkout", "autoconf", "configure", "build_up", "build_miniruby", "build_ruby", "build_all", "build_install", "test_btest", "test_basic", "test_all", "test_rubyspec"], @quiet=false, @gist=false, @timeout=10800, @logfile="/home/ko1/ruby/logs/brlog.trunk_gcc4.20201007-015723", @ruby_env=[["RUBY_DEBUG", "ci"]], @logger=#<Logger:0x000055b63fdbae98 @level=0, @progname=nil, @default_formatter=#<Logger::Formatter:0x000055b63fdbae20 @datetime_format=nil>, @formatter=nil, @logdev=#<Logger::LogDevice:0x000055b63fdbad80 @shift_period_suffix="%Y%m%d", @shift_size=1048576, @shift_age=0, @filename="/home/ko1/ruby/logs/brlog.trunk_gcc4.20201007-015723", @dev=#<File:/home/ko1/ruby/logs/brlog.trunk_gcc4.20201007-015723>, @mon_owner=nil, @mon_count=0, @mon_mutex=#<Thread::Mutex:0x000055b63fdbacb8>>>>
$$$[beg] rm -f .revision.time
$$$[end] "rm -f .revision.time" exit with 0.
$$$[beg] make update-unicode  -j6
Downloading Unicode 12.1.0 data and property files...
Downloading Unicode 12.1.0 auxiliary files...
Downloading Unicode emoji 12.1 files...
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/auxiliary/GraphemeBreakProperty.txt already exists
downloading 12.1.0/ucd/UnicodeData.txt ... /tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/auxiliary/GraphemeBreakTest.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/emoji/12.1/emoji-data.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/emoji/12.1/emoji-sequences.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/emoji/12.1/emoji-test.txt already exists
downloading emoji/12.1/emoji-variation-sequences.txt ... done
downloading emoji/12.1/emoji-zwj-sequences.txt ... done
done
downloading 12.1.0/ucd/CompositionExclusions.txt ... done
downloading 12.1.0/ucd/NormalizationTest.txt ... done
downloading 12.1.0/ucd/CaseFolding.txt ... done
downloading 12.1.0/ucd/SpecialCasing.txt ... uncommon.mk:1457: recipe for target 'update-unicode-files' failed
$$$[end] "make update-unicode  -j6" exit with 512.
$$$[beg] make update-download -j6
Downloading bundled gem minitest-5.14.2...
Downloading bundled gem power_assert-1.2.0...
Downloading bundled gem rake-13.0.1...
Downloading bundled gem test-unit-3.3.6...
Downloading bundled gem rexml-3.2.4...
tool/config.guess already exists
tool/config.sub already exists
Downloading bundled gem rss-0.2.9...
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/minitest-5.14.2.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/power_assert-1.2.0.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rake-13.0.1.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rexml-3.2.4.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/test-unit-3.3.6.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rss-0.2.9.gem' failed
$$$[end] "make update-download -j6" exit with 512.
$$$[beg] make update-rubyspec -j6
make: Nothing to be done for 'update-rubyspec'.
$$$[end] "make update-rubyspec -j6" exit with 0.
$$$[beg] make update-src      -j6
Already up to date.
Current branch master is up to date.
Latest commit hash = cdc4084b0a
$$$[end] "make update-src      -j6" exit with 0.
$$$[beg] make after-update    -j6
Downloading Unicode 12.1.0 data and property files...
generating golf_prelude.c
generating enc.mk
Downloading bundled gem minitest-5.14.2...
Downloading bundled gem power_assert-1.2.0...
golf_prelude.c updated
Downloading bundled gem rake-13.0.1...
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/UnicodeData.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/CompositionExclusions.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/NormalizationTest.txt already exists
/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/data/12.1.0/ucd/CaseFolding.txt already exists
downloading 12.1.0/ucd/SpecialCasing.txt ... downloading for ext/fiddle/extlibs
downloading libffi-3.2.1.tar.gz ... Downloading bundled gem test-unit-3.3.6...
done
downloading 12.1.0/ucd/Blocks.txt ... done
downloading 12.1.0/ucd/DerivedAge.txt ... done
downloading 12.1.0/ucd/DerivedCoreProperties.txt ... done
checking md5 of .downloaded-cache/libffi-3.2.1.tar.gz ... OK
checking sha512 of .downloaded-cache/libffi-3.2.1.tar.gz ... OK
extracting .downloaded-cache/libffi-3.2.1.tar.gz into ext/fiddle
applying win32/libffi-3.2.1-mswin.patch under ext/fiddle
patching file libffi-3.2.1/src/x86/ffi.c
patching file libffi-3.2.1/src/x86/ffitarget.h
patching file libffi-3.2.1/src/x86/win64.S
patching file libffi-3.2.1/include/ffi.h.in
applying win32/libffi-3.2.1-cygwin.patch under ext/fiddle
patching file libffi-3.2.1/src/closures.c
linked ../../../tool/config.guess to ext/fiddle/libffi-3.2.1/config.guess
linked ../../../tool/config.sub to ext/fiddle/libffi-3.2.1/config.sub
running "autoconf || exit 0" under ext/fiddle/libffi-3.2.1
done
downloading 12.1.0/ucd/PropList.txt ... Downloading bundled gem rexml-3.2.4...
done
downloading 12.1.0/ucd/PropertyAliases.txt ... done
downloading 12.1.0/ucd/PropertyValueAliases.txt ... done
downloading 12.1.0/ucd/Scripts.txt ... done
Downloading bundled gem rss-0.2.9...
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/minitest-5.14.2.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/test-unit-3.3.6.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/power_assert-1.2.0.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rake-13.0.1.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rexml-3.2.4.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rss-0.2.9.gem' failed
$$$[end] "make after-update    -j6" exit with 512.
$$$[beg] make miniruby -j6
	BASERUBY = /usr/bin/ruby --disable=gems
	CC = gcc-4.8 -std=gnu99
	LD = ld
	LDSHARED = gcc-4.8 -std=gnu99 -shared
	CFLAGS = -O3 -ggdb3 -Wall -Wextra -Werror=deprecated-declarations -Werror=implicit-function-declaration -Werror=implicit-int -Werror=pointer-arith -Werror=write-strings -Wmissing-noreturn -Wno-cast-function-type -Wno-constant-logical-operand -Wno-long-long -Wno-missing-field-initializers -Wno-overlength-strings -Wno-packed-bitfield-compat -Wno-parentheses-equality -Wno-self-assign -Wno-tautological-compare -Wno-unused-parameter -Wno-unused-value -Wsuggest-attribute=format -Wsuggest-attribute=noreturn -Wunused-variable  
	XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -DRUBY_DEVEL=1 -fvisibility=hidden -fexcess-precision=standard -DRUBY_EXPORT -fPIE -DCANONICALIZATION_FOR_MATHN -I. -I.ext/include/x86_64-linux -I/tmp/ruby/v3/src/trunk_gcc4/include -I/tmp/ruby/v3/src/trunk_gcc4 -I/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/12.1.0
	CPPFLAGS =   
	DLDFLAGS = -Wl,--compress-debug-sections=zlib -fstack-protector -pie  
	SOLIBS = -lz -lpthread -lrt -lrt -lgmp -ldl -lcrypt -lm 
	LANG = 
	LC_ALL = 
	LC_CTYPE = 
	MFLAGS = -j --jobserver-fds=4,5
gcc-4.8 (Ubuntu 4.8.5-4ubuntu8) 4.8.5
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

make: 'miniruby' is up to date.
$$$[end] "make miniruby -j6" exit with 0.
$$$[beg] make ruby -j6
	BASERUBY = /usr/bin/ruby --disable=gems
	CC = gcc-4.8 -std=gnu99
	LD = ld
	LDSHARED = gcc-4.8 -std=gnu99 -shared
	CFLAGS = -O3 -ggdb3 -Wall -Wextra -Werror=deprecated-declarations -Werror=implicit-function-declaration -Werror=implicit-int -Werror=pointer-arith -Werror=write-strings -Wmissing-noreturn -Wno-cast-function-type -Wno-constant-logical-operand -Wno-long-long -Wno-missing-field-initializers -Wno-overlength-strings -Wno-packed-bitfield-compat -Wno-parentheses-equality -Wno-self-assign -Wno-tautological-compare -Wno-unused-parameter -Wno-unused-value -Wsuggest-attribute=format -Wsuggest-attribute=noreturn -Wunused-variable  
	XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -DRUBY_DEVEL=1 -fvisibility=hidden -fexcess-precision=standard -DRUBY_EXPORT -fPIE -DCANONICALIZATION_FOR_MATHN -I. -I.ext/include/x86_64-linux -I/tmp/ruby/v3/src/trunk_gcc4/include -I/tmp/ruby/v3/src/trunk_gcc4 -I/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/12.1.0
	CPPFLAGS =   
	DLDFLAGS = -Wl,--compress-debug-sections=zlib -fstack-protector -pie  
	SOLIBS = -lz -lpthread -lrt -lrt -lgmp -ldl -lcrypt -lm 
	LANG = 
	LC_ALL = 
	LC_CTYPE = 
	MFLAGS = -j --jobserver-fds=4,5
gcc-4.8 (Ubuntu 4.8.5-4ubuntu8) 4.8.5
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

make: 'ruby' is up to date.
$$$[end] "make ruby -j6" exit with 0.
$$$[beg] make all -j6
	BASERUBY = /usr/bin/ruby --disable=gems
	CC = gcc-4.8 -std=gnu99
	LD = ld
	LDSHARED = gcc-4.8 -std=gnu99 -shared
	CFLAGS = -O3 -ggdb3 -Wall -Wextra -Werror=deprecated-declarations -Werror=implicit-function-declaration -Werror=implicit-int -Werror=pointer-arith -Werror=write-strings -Wmissing-noreturn -Wno-cast-function-type -Wno-constant-logical-operand -Wno-long-long -Wno-missing-field-initializers -Wno-overlength-strings -Wno-packed-bitfield-compat -Wno-parentheses-equality -Wno-self-assign -Wno-tautological-compare -Wno-unused-parameter -Wno-unused-value -Wsuggest-attribute=format -Wsuggest-attribute=noreturn -Wunused-variable  
	XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -DRUBY_DEVEL=1 -fvisibility=hidden -fexcess-precision=standard -DRUBY_EXPORT -fPIE -DCANONICALIZATION_FOR_MATHN -I. -I.ext/include/x86_64-linux -I/tmp/ruby/v3/src/trunk_gcc4/include -I/tmp/ruby/v3/src/trunk_gcc4 -I/tmp/ruby/v3/src/trunk_gcc4/enc/unicode/12.1.0
	CPPFLAGS =   
	DLDFLAGS = -Wl,--compress-debug-sections=zlib -fstack-protector -pie  
	SOLIBS = -lz -lpthread -lrt -lrt -lgmp -ldl -lcrypt -lm 
	LANG = 
	LC_ALL = 
	LC_CTYPE = 
	MFLAGS = -j --jobserver-fds=4,5
gcc-4.8 (Ubuntu 4.8.5-4ubuntu8) 4.8.5
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

generating enc.mk
making srcs under enc
making enc
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
make[1]: Nothing to be done for 'enc'.
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
/tmp/ruby/v3/src/trunk_gcc4/revision.h unchanged
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
make[1]: Nothing to be done for 'srcs'.
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
generating transdb.h
transdb.h updated
generating makefiles ext/configure-ext.mk
making trans
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
compiling /tmp/ruby/v3/src/trunk_gcc4/enc/trans/transdb.c
ext/configure-ext.mk unchanged
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/bug-14834'
linking shared-object -test-/bug_14834.so
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/load/dot.dot'
linking shared-object -test-/load/dot.dot.so
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/marshal/compat'
linking shared-object -test-/marshal/compat.so
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/bug-14834'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/load/dot.dot'
linking transcoder transdb.so
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/-test-/marshal/compat'
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
making encs
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/bigdecimal'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/coverage'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/bigdecimal'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/coverage'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/date'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/digest'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/date'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/digest'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/io/console'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/fiddle'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/json'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/io/console'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/monitor'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/nkf'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/monitor'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/json'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/objspace'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/fiddle'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/nkf'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/pathname'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/objspace'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/pty'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/pathname'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/psych'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/pty'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/rubyvm'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/ripper'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/rubyvm'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/openssl'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/ripper'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/psych'
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
make[1]: Nothing to be done for 'encs'.
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/socket'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/syslog'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/syslog'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/openssl'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/socket'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/digest/sha2'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4/ext/json/generator'
linking shared-object json/ext/generator.so
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/digest/sha2'
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4/ext/json/generator'
make[2]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
make[2]: 'ruby' is up to date.
make[2]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
make[1]: Entering directory '/tmp/ruby/v3/build/trunk_gcc4'
*** Following extensions are not compiled:
dbm:
	Could not be configured. It will not be installed.
	Check ext/dbm/mkmf.log for more details.
*** Fix the problems, then remove these directories and try again if you want.
make[1]: Leaving directory '/tmp/ruby/v3/build/trunk_gcc4'
$$$[end] "make all -j6" exit with 0.
$$$[beg] make install -j6
Downloading bundled gem minitest-5.14.2...
Downloading bundled gem power_assert-1.2.0...
Downloading bundled gem rake-13.0.1...
Downloading bundled gem test-unit-3.3.6...
Downloading bundled gem rexml-3.2.4...
Downloading bundled gem rss-0.2.9...
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rake-13.0.1.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/test-unit-3.3.6.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rexml-3.2.4.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/rss-0.2.9.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/power_assert-1.2.0.gem' failed
/tmp/ruby/v3/src/trunk_gcc4/defs/gmake.mk:262: recipe for target 'gems/minitest-5.14.2.gem' failed
$$$[end] "make install -j6" exit with 512.
raw logfile